API_​StoryCmdID

Action code for the story settings command.

    typedef enum {
        APIStory_GoTo,
        APIStory_Delete,
        APIStory_InsAbove,
        APIStory_InsBelow,
        APIStory_SetHeight,
        APIStory_Rename,
        APIStory_SetElevation,
        APIStory_SetDispOnSections
    } API_StoryCmdID;

 

Members

APIStory_GoTo
change the active story
APIStory_Delete
delete a story
APIStory_InsAbove
insert a new story above an existing one
APIStory_InsBelow
insert a new story below an existing one
APIStory_SetHeight
change the height of an existing story. It results that all of the above stories will have modified story level.
APIStory_Rename
change the name of an existing story
APIStory_SetElevation
change the elevation of an existing story
APIStory_SetDispOnSectionsFeaturing API 12
change the visibility of Story Level Lines in section window of an existing story

 

Remarks

Refer to the API_StoryCmdType structure for further details on modifying the story structure of Archicad.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Environment.h

 

See Also

API_StoryCmdType, API Types