Parameters of the change story settings command.
typedef struct { API_StoryCmdID action; short index; bool dispOnSections; bool dontRebuild; double height; double elevation; GS::uchar_t uName [API_UniLongNameLen]; Int32 filler_2[4]; } API_StoryCmdType;
Members
- action
- Action done in Story Settings dialog.
- index
- An existing story index, which the command is performed upon.
- dispOnSections
- The level line of the given story will or will not appear in any model window; in the case of
APIStory_SetDispOnSections
. - dontRebuild
- Do not will be called rebuild or redraw after Go To Story command.
- height
- Story height value; in the case of
APIStory_SetHeight, APIStory_InsAbove
, orAPIStory_InsBelow
commands. - elevation
- Story elevation value; in the case of
APIStory_SetElevation
. - uName[API_UniLongNameLen]
- Unicode name of the story; in the case of
APIStory_Rename, APIStory_InsAbove
orAPIStory_InsBelow
commands.
Remarks
The command is related to an existing story. It must be referred by the index
field of the structure. Possible operations are listed in the API_StoryCmdID list.
Note, that in case story operations are disabled in team projects; except changing the active story.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Environment.h