API_​StoryInfo

Story information of the active project.

    typedef struct {
        short                  firstStory;
        short                  lastStory;
        short                  actStory;
        bool                   filler_1;
        bool                   skipNullFloor;
        API_StoryType          **data;
        Int32                  filler_2;
        API_GhostStoryType     ghostStory;
        Int32                  filler_3[4];
    } API_StoryInfo;

 

Members

firstStory
First story index.
lastStory
Last story index.
actStory
Actual story index.
skipNullFloor 6.1
Floor indices above ground-floor level start with 1 instead of 0.
data
Array of data to hold the parameters of each story. Refer to API_StoryType for further details.
ghostStory
Ghost story settings. Refer to API_GhostStoryType for further details.

 

Remarks

This structure corresponds to the “Story Settings…” dialog of Archicad. The parameters of each story are contained, as well as the parameters ghost story settings.

Do not forget to dispose the data array if it is not needed any more.

Call the ACAPI_Environment function with the APIEnv_GetStorySettingsID or APIEnv_ChangeStorySettingsID function codes to operate on this data.

Note, that a virtual story is also exported, above the top story. This story does not exist, but the level parameter is important to calculate the height of the top story.

Featuring API 10  Ghost story settings can be retrieved by the APIEnv_GetGhostStorySettingsID environment function also.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

API_StoryType
API_GhostStoryType
APIEnv_GetStorySettingsID
APIEnv_ChangeStorySettingsID
APIEnv_GetGhostStorySettingsID
API Types