API_​StoryType

Parameters of one story.

    typedef struct {
        short           index;
        short           floorId;
        bool            notMine;
        bool            dispOnSections;
        short           filler_1;
        double          level;
        GS::uchar_t     uName [API_UniLongNameLen];
        Int32           filler_2[4];
    } API_StoryType;

 

Members

index
The story index.
floorId
Unique ID of the story.
notMine
The story belongs to another client; in case of a team project.
dispOnSections 17
Story level lines should appear on sections and elevations.
level
The story level.
uName [API_UniLongNameLen] 21
The name of the story.

 

Remarks

Each parameter can be set in the “Story Settings…” dialog of Archicad are represented in the structure. The story height should be calculated based on neighboring stories.

Refer to API_StoryInfo structure for further details.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

API_StoryInfo, API Types