API_​StoryVisibility

Determines the appearance of model elements on different stories.

    typedef struct {
        bool      showOnHome;
        bool      showAllAbove;
        bool      showAllBelow;
        bool      filler_1;
        short     showRelAbove;
        short     showRelBelow;
    } API_StoryVisibility;

 

Members

showOnHome
Show the element on its own story only.
showAllAbove
Show the element on all stories above its own story.
showAllBelow
Show the element on all stories below its own story.
showRelAbove
Show the element on showRelAbove stories above its own story.
showRelBelow
Show the element on showRelBelow stories below its own story.

 

Remarks

For API_SlabType, API_RoofType and API_MeshType elements you can set a a desired number of stories above and below their own story on which to display their contour line and cover fill. API_BeamType and API_ObjectType contain this structure but this new feature was not extended for these elements.

 

Requirements

Version: API 6.1 or later
Header: APIdefs_Elements.h

 

See Also

API_BeamType, API_ObjectType, API_LampType, API_SlabType, API_RoofType, API_MeshType
API_LegacyPrefs
API Types