API_​StructureDisplay

This is the enumeration of the Partial Structure Display.

    typedef enum {
        API_EntireStructure,
        API_CoreOnly,
        API_WithoutFinishes,
        API_StructureOnly
    } API_StructureDisplay;

 

Members

API_EntireStructure
This is the default setting.
API_CoreOnly
Only those structures defined as “Core” will be displayed.
API_WithoutFinishes
The entire structure, except for skins/components defined as “Finish”, is displayed.
API_StructureOnly Modified in 14
Non-Structural element will not be displayed.

 

Remarks

You are able to get and change the Partial Structure Display via APIEnv_GetStructureDisplayID and APIEnv_ChangeStructureDisplayID functions.
This function allows you to display and output composite and complex elements in simplified form.

 

Requirements

Version: API 12 or later
Header: APIdefs_Environment.h

 

See Also

API_UIStructureDisplay, API Types