Describes the filter for the different subtypes of elements.
enum API_SubElementType : UInt64{ APISubElement_MainMarker = 0x0000000000000001, APISubElement_SHMarker = 0x0000000000000002, APISubElement_CommonMarker = 0x0000000000000004, APISubElement_CWFrameClass = 0x0000000000000008, APISubElement_CWPanelClass = 0x0000000000000010, APISubElement_CWJunction = 0x0000000000000020, APISubElement_CWAccessory = 0x0000000000000040, APISubElement_StairRiser = 0x0000000000000080, APISubElement_StairTread = 0x0000000000000100, APISubElement_StairStructure = 0x0000000000000200, APISubElement_StairFPDMarker = 0x0000000000000400, APISubElement_StairRCPDMarker = 0x0000000000000800, APISubElement_RailingNode = 0x0000000000001000, APISubElement_RailingSegment = 0x0000000000002000, APISubElement_RailingPost = 0x0000000000004000, APISubElement_RailingInnerPost = 0x0000000000008000, APISubElement_RailingRail = 0x0000000000010000, APISubElement_RailingHandrail = 0x0000000000020000, APISubElement_RailingToprail = 0x0000000000040000, APISubElement_RailingPanel = 0x0000000000080000, APISubElement_RailingBaluster = 0x0000000000100000, APISubElement_RailingPattern = 0x0000000000200000, APISubElement_RailingBalusterSet = 0x0000000000400000, APISubElement_RailingRailEnd = 0x0000000000800000, APISubElement_RailingHandrailEnd = 0x0000000001000000, APISubElement_RailingToprailEnd = 0x0000000002000000, APISubElement_RailingRailConnection = 0x0000000004000000, APISubElement_RailingHandrailConnection = 0x0000000008000000, APISubElement_RailingToprailConnection = 0x0000000010000000, APISubElement_RailingFinish = 0x0000000020000000, APISubElement_CWTag = 0x1000000000000000, APISubElement_NoElem = 0x2000000000000000, APISubElement_NoParams = 0x4000000000000000 };
Remarks
This enumeration was renamed in Archicad 25, the previous name was
API_SubElemMemoMaskType
.
Requirements
- Version: API 12 or later
- Header: APIdefs_Elements.h