API_​SubSet

Represents a Subset in the Layout Book.

    typedef struct {
        GS::uchar_t            name[API_LongNameLen];
        bool                   doNotInclude;
        bool                   customNumbering;
        bool                   continueNumbering;
        bool                   useUpperPrefix;
        bool                   addOwnPrefix;
        bool                   filler[3];
        GS::uchar_t            customNumber[API_LongNameLen];
        GS::uchar_t            autoNumber[API_LongNameLen];
        API_NumberingStyle     numberingStyle;
        Int32                  startAt;
        GS::uchar_t            ownPrefix[API_LongNameLen];
    } API_SubSet;

 

Members

name
Name of the Subset.
doNotInclude
Do not include this Subset in ID sequence.
customNumbering
Custom ID or automatically generated.
continueNumbering
Continue using ID assignment of upper levels.
useUpperPrefix
Use prefix and IDs of upper levels.
addOwnPrefix
Add own prefix for this Subset.
customNumber
Custom Number string.
autoNumber
Automatic Numbering string.
numberingStyle
ID appearance style.
startAt
Start numbering at.
ownPrefix
Prefix for the Subset.

 

Remarks

You are able to get the default Subset settings via APIDb_GetSubSetDefaultID function.
APIDb_CreateSubSetID creates a Subset in the Layout Book.

 

Requirements

Version: API 12 or later
Header: APIdefs_Database.h

 

See Also

API_NumberingStyle, APIDb_GetSubSetDefaultID, APIDb_CreateSubSetID, API Types