API_​SunAngleSettings

Sun angle settings.

    typedef struct {
        double                                     sunAzimuth;
        double                                     sunAltitude;
        API_SunAngleSettings_SunPositionOption     sunPosOpt;
        unsigned short                             year;
        unsigned short                             month;
        unsigned short                             day;
        unsigned short                             hour;
        unsigned short                             minute;
        unsigned short                             second;
        bool                                       summerTime;
        bool                                       filler;
    } API_SunAngleSettings;

 

Members

sunAzimuth
rotation angle of the Sun around the target
sunAltitude
Sun’s altitude
sunPosOpt
this enumeration tells if the azimuth and altitude values have to be considered or the Sun position is given with a date (project location-dependent!)
year New in API 22
date’s year.
month
date’s month
day
date’s day
hour
date’s hour
minute
date’s minute
second
date’s second
summerTime
this option controls daylight saving

 

Remarks

This structure corresponds to Sun parameters set in the “3D Projection Settings…” dialog of Archicad.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_SunAngleSettings_SunPositionOption, API_AxonoPars, API_PerspPars, API Types