API_​SunAngleSettings_​SunPositionOption

Sun position options for calculating Sun’s angles.

    typedef enum {
        API_SunPosition_GivenByAngles,
        API_SunPosition_GivenByDate
    } API_SunAngleSettings_SunPositionOption;

 

Members

API_SunPosition_GivenByAngles
The Sun’s position will be the exact azimuth and altitude angles given in the API_SunAngleSettings struct.
API_SunPosition_GivenByDate
The Sun’s position will be calculated from the project location and the date given in the API_SunAngleSettings struct.

 

Remarks

The options correspond to the different Sun position setting choices in the “3D Projection Settings…” dialog of Archicad.

 

Requirements

Version: API 21 or later
Header: APIdefs_Elements.h

 

See Also

API_SunAngleSettings
API Types