API_​SunInfo

Parameters of the sunlight.

    typedef struct {
        API_RGBColor     sunRGB;
        API_RGBColor     ambientRGB;
        short            sunIntensity;
        short            ambientIntensity;
        short            sunToAmbient;
        short            filler_1;
    } API_SunInfo;

 

Members

sunRGB
Color of the directional light
ambientRGB
Color of the ambient light
sunIntensity
Intensity of the directional light [0..100]
ambientIntensity
Intensity of the ambient light [0..100]
sunToAmbient
Contribution to ambient [0..100]

 

Remarks

This structure is used when you get information about the sun. See the APIEnv_GetSunSetsID environment function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_GetSunSetsID, API_RGBColor, API Types