API_​Surface3D

Describes a 3D surface. Obsolete

    typedef struct {
        API_Interval     intervalU;
        API_Interval     intervalV;
        bool             validPlane;
        bool             filler_1;
        short            filler_2[3];
        API_Plane3D      plane;
        double           filler_3;
    } API_Surface3D;

 

Members

intervalU
u1..u2 interval of the surface segment with possible periodicity (2π or else).
intervalV
v1..v2 interval of the surface segment with possible periodicity (2π or else)
validPlane
Plane member contains valid data.
plane
Optional host plane pointer of the surface (i.e. plane of a cylinder)

 

Requirements

Version: API 12.0 or later
Header: APIdefs_Base.h

 

See Also

API_GridMeshDirection, API_GridMeshHead, API_GridMeshVertex, API_GridMeshEdge, API_GridEdgeInfo
API_GridMeshLine, API_GridMeshPolygon, API_GridMesh
API_Interval, API_Plane3D
API Types