API_​SymbolHatchDef

Describes the details of a symbol fill.

    typedef struct {
        API_Coord          **sfill_HotSpots;
        API_SFill_Line     **sfill_Lines;
        API_SFill_Arc      **sfill_Arcs;
        API_Polygon        **sfill_SolidFills;
        API_Coord          **sfill_FillCoords;
        Int32              **sfill_SubPolys;
        API_PolyArc        **sfill_PolyArcs;
    } API_SymbolHatchDef;

 

Members

sfill_HotSpots
The coordinates of the hotspots in the symbol fill. The number of hotspots is given in the hotNumb field of the API_FilltypeType structure.
sfill_Lines
The description of the line items in the symbol fill. The number of line items is given in the linNumb field of the API_FilltypeType structure.
sfill_Arcs
The description of the arc items in the symbol fill. The number of arc items is given in the arcNumb field of the API_FilltypeType structure.
sfill_SolidFills
The description of all (!) the solid fill items in the symbol fill. The number of solid fill items is given in the filNumb field of the API_FilltypeType structure. The polygons and all the related information is stored sequentially. The following three fields complete the description of the fill polygons.
sfill_FillCoords
All the vertices of all the solid fill items in the symbol fill.
sfill_SubPolys
All the subpolygons of all the solid fill items in the symbol fill.
sfill_PolyArcs
All the polygon arc segments of all the solid fill items in the symbol fill.

 

Remarks

None.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Attributes.h

 

See Also

API_Coord, API_SFill_Line, API_SFill_Arc, API_Polygon, API_PolyArc, API_FilltypeType , API Types