Symbol transformation parameters.
typedef struct { API_Coord loc; double angle; double xRatio; double yRatio; } API_SyTran;
Members
- loc
- The location of the referenced library part.
- angle
- The rotation angle.
- xRatio
- ‘x’ scaling.
- yRatio
- ‘y’ scaling.
Remarks
This data structure gives information on the transformation parameters of a plaved Library Part.
The transformation chain is: placement, rotation, scaling; respectively. Scaling is done in the rotated coordinate system. Refer to the ACAPI_Element_GetSyTran function for more details.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Elements.h