Contains parameters to calculate the maximal distance of a spline segment and a set of coordinates.
typedef struct { API_Coord **splCoords; API_SplineDir **splDirs; Int32 nFit; Int32 segment; API_Coord **polyCoords; Int32 nCoords; } API_TestSplineFit;
Members
- splCoords
- Fit points of the spline.
- splDirs
- Direction vectors at the fit points.
- nFit
- Number of fit points.
- segment
- Segment of the spline to be tested. It can be in the range of [1…nFit-1].
- polyCoords
- Coordinates to be tested.
- nCoords
- Number of test coordinates.
Remarks
Call the APIAny_GetSplineMaxDistID function to operate on this data. Refer to the API_ElementMemo structure to get information on the spline parameters.
Do not forget to dispose the handles passed if they are not needed any more.
Requirements
- Version: API 3.1 or later
- Header: APIdefs_Goodies.h