API_​TextLinePars

Represents some text to measure its length.

    typedef struct {
        short             index;
        bool              drvScaleCorr;
        bool              wantsLongestIndex;
        short             wFont;
        short             wFace;
        double            wSlant;
        double            wSize;
        char              *lineStr;
        GS::UniString     *lineUniStr;
    } API_TextLinePars;

 

Members

index

-1

last line length

0

longest line length

> 0

length of the nth line

drvScaleCorr
If true: scale the text to the model, if false: in mms.
wantsLongestIndex 21
If index is 0 :: true: return longest line’s index, false: don’t return longest line’s index.
wFont
Font attribute index.
wFace
Style (face) of text:

APIFace_Plain

Plain text

APIFace_Bold

Bold

APIFace_Italic

Italic

APIFace_Underline

Underline

APIFace_Outline

Outlined (Macintosh only)

APIFace_Shadow

Shadow (Macintosh only)

wSlant
Slant angle [radian] (PI/2 is plain text).
wSize
Character height in mms.
lineStr
The text to measure.
lineUniStr 21
Unicode text to measure.

 

Remarks

For further details see the APIAny_GetTextLineLengthID goodie function.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

APIAny_GetTextLineLengthID,
API Types