Texture reference.
typedef struct { short status; bool missingPict; bool filler_1; Int32 filler_2; double xSize; double ySize; double rotAng; Int32 filler_3; Int32 irtxt; GS::uchar_t texName [API_UniLongNameLen]; IO::Location *fileLoc; bool withoutExtension; bool filler_4; short filler_5; } API_Texture;
Members
- status
- Texture status
- missingPict
- Picture is missing (output only)
- xSize
- X size of the picture in model space.
- ySize
- Y size of the picture in model space.
- rotAng
- Rotation angle in radians.
- irtxt
- for internal use
- texName
- Texture file name (Unicode string)
- fileLoc
- Texture file specification
- withoutExtension
- [in] Indicates that the extension was not appended to the texture name.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Attributes.h