Determines the type of the texture projection.
typedef enum { APITextureProjectionType_Invalid, APITextureProjectionType_Planar, APITextureProjectionType_Default, APITextureProjectionType_Cylindric, APITextureProjectionType_Spheric, APITextureProjectionType_Box } API_TextureProjectionTypeID;
Members
- APITextureProjectionType_Invalid
- The texture projection type is not set.
- APITextureProjectionType_Planar
- The texture projection type is Planar.
- APITextureProjectionType_Cylindric
- The texture projection type is Cylindric.
- APITextureProjectionType_Spheric
- The texture projection type is Spheric.
- APITextureProjectionType_Box
- The texture projection type is Box.
Requirements
- Version: API 16 or later
- Header: APIdefs_Elements.h