API_​ToolBoxInfo

Contains information on the current state of the tolbox.

    typedef struct {
        Int32               nTools;
        API_ToolBoxItem     **data;
        API_ToolBoxItem     activeTool;
        Int32               filler_1[6];
    } API_ToolBoxInfo;

 

Members

nTools
number of tools installed (internal, subtypes)
data
the tools themselves
activeTool
the tool which is currently active

 

Remarks

Don’t forget to dispose the data handle.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Environment.h

 

See Also

API Types,
APIEnv_GetToolBoxInfoID