API_​Tranmat

A 3*4 transformation matrix

    typedef struct {
        double     tmx[12];
    } API_Tranmat;

 

Members

tmx[12]
the matrix coefficients

 

Remarks

This structure represents a standard 3*4 transformation matrix for linear transformations.

The transformed coordinates are calculated using the below formula:


x' = tmx[0] * x + tmx[1] * y + tmx[2]  * z + tmx[3]
y' = tmx[4] * x + tmx[5] * y + tmx[6]  * z + tmx[7]
z' = tmx[8] * x + tmx[9] * y + tmx[10] * z + tmx[11]

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Base.h

 

See Also

API Types