API_​TrimTypeID

The type of the trim connection link between two construction elements.

    typedef enum {
        APITrim_No          = 'TRNO',
        APITrim_KeepInside  = 'TRIN',
        APITrim_KeepOutside = 'TROU',
        APITrim_KeepAll     = 'TRAL'
   } API_TrimTypeID;

 

Members

APITrim_No
No trim connection
APITrim_KeepInside
Keep the inside part of the trimmed element
APITrim_KeepOutside
Keep the outside part of the trimmed element
APITrim_KeepAll
Keep the all trimmed element

 

Remarks

These enumerators are used with the ACAPI_Element_Trim_ElementsWith and ACAPI_Element_Trim_GetTrimType functions.

 

Requirements

Version: API 15 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_Element_Trim_ElementsWith
ACAPI_Element_Trim_GetTrimType
API Types