API_​UmatType

Representation of a 3D material.

    typedef struct {
        API_3D_Head          head;
        API_MaterialType     mater;
    } API_UmatType;

 

Members

head
Header information of this component. This specifies the type and database index.
mater
The definition of the material.

 

Remarks

This structure contains the properties of a material. These properties are described in API_MaterialType structure.

Basically there are two source of materials. First is the globally stored, the second is when they are come from an object’s GDL script. In case of GDL materials the index in the header is 0. In case of global material the value of the header is than 0. In both cases the parameters of the material can be obtained from the mater field of this structure.

The following 3D components can refer to material: API_PgonType, API_BodyType.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_3D.h

 

See Also

API_3D_Head, API_PgonType, API_BodyType, API_Component3D,
API_MaterialType,
3D Manager, API Types