General representation of a Model Display in 3D Document.
typedef struct { bool shouldUseUniformCutAttributes; bool filler_1; short uniformLineType; short uniformFillPen; short uniformFillBkgPen; bool shouldUseUncutSurfaceFill; bool filler_2[3]; API_3DCutSurfFills fillCutSurfacesWith; API_3DUncutSurfaceFillType uncutSurfaceFillType; short uncutSurfaceBkgPen; bool shouldUseElemPen; bool filler_3; short elemPen; short shadFillPen; API_AttributeIndex shadFill; short shadFillBkgPen; short shadContPen; API_3DHiddenEdgeVisibility hiddenEdgeVisibility; API_AttributeIndex hiddenEdgeLineType; short hiddenEdgeLinePen; short filler_4; API_3DOnCutPlaneVisibility onCutPlaneVisibility; short filler_5[2]; } API_UniformAttributeOptions;
Members
- shouldUseUniformCutAttributes
- Use uniform cut attributes.
- uniformLineType
- Uniform line type index.
- uniformFillPen
- Uniform fill index.
- uniformFillBkgPen
- Background color of the uniform fill.
- shouldUseUncutSurfaceFill
- Use uncut surface fill.
- fillCutSurfacesWith
- How to display the cut surfaces.
- uncutSurfaceFillType
- How to display the uncut surfaces.
- uncutSurfaceBkgPen
- Background color of the uncut surface.
- shouldUseElemPen
- Use elem pen.
- elemPen
- Elem pen index.
- shadFill
- Shadow fill index.
- shadFillPen
- Shadow fill pen.
- shadFillBkgPen
- Shadow fill background pen.
- shadContPen
- Shadow contour pen.
- hiddenEdgeVisibility
- Show or hide hidden edges.
- hiddenEdgeLineType
- Hidden edge line type.
- hiddenEdgeLinePen
- Hidden edge line pen.
- onCutPlaneVisibility
- Show or hide hidden cut lines.
Remarks
You are able to get and change the default settings of 3D document via APIEnv_GetDocumentFrom3DDefaultsID and APIEnv_ChangeDocumentFrom3DDefaultsID functions.
APIEnv_GetDocumentFrom3DSettingsID and APIEnv_ChangeDocumentFrom3DSettingsID function retrieves and modifies the settings of an existing 3D document database.
Requirements
- Version: API 12 or later
- Header: APIdefs_Environment.h