Possible values for unit preferences; length type formats.
typedef enum { APIUnit_Metric, APIUnit_Centimetric, APIUnit_Millimetric, APIUnit_FootInch, APIUnit_FootDecInch, APIUnit_DecFoot, APIUnit_Inch, APIUnit_DecInch, APIUnit_Decimetric, APIUnit_DecYard, APIUnit_Gallon } API_UnitTypeID;
Members
- APIUnit_Metric
- coordinates / lengths are displayed in meters
- APIUnit_Centimetric
- coordinates / lengths are displayed in centimeters
- APIUnit_Millimetric
- coordinates / lengths are displayed in millimeters
- APIUnit_FootInch
- coordinates / lengths are displayed in foot and inch
- APIUnit_FootDecInch
- coordinates / lengths are displayed in foot and decimal inch
- APIUnit_DecFoot
- coordinates / lengths are displayed in decimal foot
- APIUnit_Inch
- coordinates / lengths are displayed in inches
- APIUnit_DecInch
- coordinates / lengths are displayed in decimal inches
- APIUnit_Decimetric
- valid only for volume calculation units
- APIUnit_DecYard
- valid only for volume calculation units
- APIUnit_Gallon
- valid only for volume calculation units
Remarks
Refer to the API_UnitPrefs record for further details.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Environment.h