API_​UserControlType

Describes the different types of user controls.

    typedef enum {
        APIUserControlType_Pen,
        APIUserControlType_PenWithNull,
        APIUserControlType_PolyFill,
        APIUserControlType_WallFill,
        APIUserControlType_WallCompFill,
        APIUserControlType_AllFill,
        APIUserControlType_AllFillGradNoComp,
        APIUserControlType_WallSetsFill,
        APIUserControlType_WallComposites,
        APIUserControlType_SlabSetsFill,
        APIUserControlType_SlabComposites,
        APIUserControlType_RoofSetsFill,
        APIUserControlType_RoofComposites,
        APIUserControlType_ShellSetsFill,
        APIUserControlType_ShellComposites,
        APIUserControlType_OnlyCompFill,
        APIUserControlType_Material,
        APIUserControlType_MaterialWithGeneral,
        APIUserControlType_Layer,
        APIUserControlType_ZoneCategory,
        APIUserControlType_DashedLine,
        APIUserControlType_SymbolLine,
        APIUserControlType_CoverFill,
        APIUserControlType_WallProfile,
        APIUserControlType_BeamProfile,
        APIUserControlType_ColumnProfile,
        APIUserControlType_AllProfile,
        APIUserControlType_PolyFillWithGradient,
        APIUserControlType_BuildingMaterial,
        APIUserControlType_HandrailProfile,
        APIUserControlType_OtherGDLObjectProfile
    } API_UserControlType;

 

Members

APIUserControlType_Pen
pen control
APIUserControlType_PenWithNull
pen control with background pen
APIUserControlType_PolyFill
polygon fill control (drafting fills)
APIUserControlType_WallFill
wall fill control (cut fills)
APIUserControlType_WallCompFill
wall fill control without composites
APIUserControlType_AllFill
all fill types control
APIUserControlType_AllFillGradNoComp 17
all fill types without composites
APIUserControlType_WallSetsFill
fill control like in the Wall Settings dialog
APIUserControlType_WallComposites 15
composite control like in the Wall Settings dialog
APIUserControlType_SlabSetsFill
fill control like in the Slab Settings dialog
APIUserControlType_SlabComposites 15
composite control like in the Slab Settings dialog
APIUserControlType_RoofSetsFill
fill control like in the Roof Settings dialog
APIUserControlType_RoofComposites 15
composite control like in the Roof Settings dialog
APIUserControlType_ShellSetsFill 15
fill control like in the Shell Settings dialog
APIUserControlType_ShellComposites 15
composite control like in the Shell Settings dialog
APIUserControlType_OnlyCompFill 10
fill control containing composite fills only
APIUserControlType_Material
material control
APIUserControlType_MaterialWithGeneral
material control with general material
APIUserControlType_Layer
layer control
APIUserControlType_ZoneCategory
zone category control
APIUserControlType_DashedLine
dashed line control
APIUserControlType_SymbolLine
all line types
APIUserControlType_CoverFill 6.1
cover fill type control
APIUserControlType_WallProfile 10
wall profiles control
APIUserControlType_BeamProfile 10
beam profiles control
APIUserControlType_ColumnProfile 10
column profiles control
APIUserControlType_AllProfile 10
all profiles control
APIUserControlType_PolyFillWithGradient 10
polygon fill control with gradient fills
APIUserControlType_BuildingMaterial 10
building material control
APIUserControlType_HandrailProfile New in API 21
handrail profiles control
APIUserControlType_OtherGDLObjectProfile New in API 21
other GDL object profiles control

 

Remarks

These are the special constants used in ACAPI_Interface (APIIo_SetUserControlCallbackID, …) function. They define the attribute set used in the user control.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Interface.h

 

See Also

API_UCCallbackType
APIIo_SetUserControlCallbackID
API Types