API_​UserData

Custom data record attached to element sets.

    typedef struct {
        short              dataVersion;
        unsigned short     platformSign;
        GSFlags            flags;
        Int32              filler_1;
        GSHandle           dataHdl;
    } API_UserData;

 

Members

dataVersion
the version of the user data
platformSign
the platform the data was created on; defines the byte ordering (can be GS::Win_Platform_Sign, GS::Mac_Platform_Sign or GS::Mactel_Platform_Sign 10)
flags
APIUserDataFlag_Pickup — copy userdata into default at element parameter transfer
APIUserDataFlag_SkipRecalcAndDraw — ACAPI_Element_SetUserData skips recalc and redraw (input only control flag)
APIUserDataFlag_FillWith — inject userdata into element from default
dataHdl
handle containing the user data (arbitrary size)

 

Remarks

This structure is used to store additional data to element sets with the ACAPI_ElementSet_Create function. You can retrieve the user data attached to an element set with ACAPI_ElementSet_GetData.

APIUserDataFlag_Copy and APIUserDataFlag_Merge were removed in Archicad 18.

APIUserDataFlag_UndoAble was removed in Archicad 20; all user data operations should be undoable.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Elements.h

 

See Also

ACAPI_ElementSet_Create
ACAPI_ElementSet_GetData
Element Set Manager
API Types