A container that can store different types of data.
typedef struct { API_VariantType type; Int32 intValue; double doubleValue; bool boolValue; GS::UniString uniStringValue; API_Guid guidValue; } API_Variant;
Members
- type
- Type of the data that the variant stores
Meaning
API_PropertyIntegerValueType
Variant with an integer value
API_PropertyRealValueType
Variant with a real (double) value
API_PropertyStringValueType
Variant with a string value
API_PropertyBooleanValueType
Variant with a boolean value
API_PropertyGuidValueType
Variant with a GUID value
- intValue
- Integer value
- doubleValue
- Real value
- boolValue
- Boolean value
- uniStringValue
- String value
- guidValue
- GUID value
Requirements
- Version: API 20 or later
- Header: APIdefs_Properties.h
See Also
API_SingleVariant
API_ListVariant
API_SingleEnumerationVariant