Describes the status of a variant value.
typedef enum { API_VariantStatusNull, API_VariantStatusUserUndefined, API_VariantStatusNormal } API_VariantStatus;
Members
- APIVariantStatusNull
- Indicates that the variant is invalid in some way, e.g., it is a result of an unsuccesful operation.
- APIVariantStatusUserUndefined
- The variant is explicitly set to undefined by the user, but it is still valid.
- APIVariantStatusNormal
- The variant has a usable and valid value.
Requirements
- Version: API 22 or later
- Header: APIdefs_Properties.h