Options for vectorial sun shadow generation in the 3D window.
typedef enum { APIVectShad_Off, APIVectShad_ContOff_AllSurf, APIVectShad_ContOn_AllSurf, APIVectShad_ContOff_OneLevel, APIVectShad_ContOn_OneLevel } API_VectorShadowID;
Members
- APIVectShad_Off
-
- Sun shadows are not generated
- APIVectShad_ContOff_AllSurf
-
- Sun shadows on all surfaces without contours
- APIVectShad_ContOn_AllSurf
-
- Sun shadows on all surfaces with contours
- APIVectShad_ContOff_OneLevel
-
- Sun shadows on a single level without contours
- APIVectShad_ContOn_OneLevel
-
- Sun shadows on a single level without contours
Remarks
The API_VectorShadowID
type is used in the API_3DWindowInfo structure.
The elevation of the horizontal plane for shadow generaion on a single level is given in the shadowElevation
field of API_3DWindowInfo.
Requirements
- Version: API 3.1 or later
- Header: APIdefs_Environment.h
See Also
APIEnv_Get3DWindowSetsID
APIEnv_Change3DWindowSetsID
API_3DWindowInfo
API Types