API_​VerticalLink

Option for anchoring the vertical position of an opening within the wall or the roof.

    typedef struct {
        API_VerticalLinkID     linkType;
        short                  filler_1;
        short                  linkValue;
    } API_VerticalLink;

 

Members

linkType
Type of the vertical anchor

API_VerticalLinkID

Meaning

API_NoLink  Featuring API 15

Undefined vertical link type, not applicable for windows/doors and skylights

API_LinkSillToWallBottom

Position the sill of the opening relative to the bottom of the containing wall

API_LinkSillToStory

Position the sill of the opening relative to a given story

API_LinkHeaderToWallBottom

Position the header of the opening relative to the bottom of the containing wall

API_LinkHeaderToStory

Position the header of the opening relative to a given story

API_LinkSkylightToRoofPivot  Featuring API 15

Position the skylight anchor vertically relative to the roof pivot lines

API_LinkSkylightToStory  Featuring API 15

Position the skylight anchor vertically relative to a given story

API_LinkSkylightToShellBase  Featuring API 15

Position the skylight anchor relative to ShellBase

API_LinkSillToWallTop  Featuring API 17

Position the sill of the opening relative to the top of the containing wall

API_LinkHeaderToWallTop  Featuring API 17

Position the header of the opening relative to the top of the containing wall

linkValue
The index of the anchor story if linked to story, 0 otherwise.

 

Remarks

This structure defines the vertical anchor

  • of a window/door element (see API_WindowType), to wall or story, by sill height or header,
  • of a skylight element (see API_SkylightType), to roof or story, by the selected anchor point.

 

Requirements

Version: API 10 or later
Header: APIdefs_Elements.h

 

See Also

API_WindowType, API_SkylightType, API_OpeningBaseType, API Types