API_​VertType

Representation of a 3D vertex.

    typedef struct {
        API_3D_Head     head;
        double          x;
        double          y;
        double          z;
    } API_VertType;

 

Members

head
Header information of this component. This specifies the type and database index.
x, y, z
The 3 coordinates of the point in the model space.

 

Remarks

A node in the x-y-z space, defined by its 3 coordinates.

The vertices are the endpoints of the edges. In the API_EdgeType structure the vert1, vert2 fields refers to an API_VertType component by index. With these indices can be used to retrieve the given vertices from the database.

Accessing vertices are based on a body. First you must get a body by ACAPI_3D_GetComponent and just after is obtainable its components.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_3D.h

 

See Also

API_3D_Head, API_Component3D,
3D Manager, API Types