API_​VLNumType

The possible values for a numeric parameter.

    typedef struct {
        double          value;
        double          lowerLimit;
        double          upperLimit;
        double          stepBeg;
        double          stepVal;
        UInt32          flags;
        Int32           filler_1;
        GS::uchar_t     valueDescription [API_UAddParNumDescLen];
    } API_VLNumType;

 

Members

value
the value itself when no limits are defined
lowerLimit
the value when one of the APIVLVal_LowerLimit or APIVLVal_LowerEqual flags is set
upperLimit
the value when one of the APIVLVal_UpperLimit or APIVLVal_UpperEqual flags is set
stepBeg
the start value when the APIVLVal_Step flag is set
stepVal
the step value when the APIVLVal_Step flag is set
flags
the possible value range modifiers; only one of these can be set

modifier

meaning

APIVLVal_LowerLimit

the value of the parameter is greater than lowerLimit

APIVLVal_LowerEqual

the value of the parameter is greater than or equal to lowerLimit

APIVLVal_UpperLimit

the value of the parameter is less than upperLimit

APIVLVal_UpperEqual

the value of the parameter is less than or equal to upperLimit

APIVLVal_Step

the value of the parameter can be equal to any value in the form of stepBeg+n*stepVal, where n ? 0

valueDescription[API_UAddParNumDescLen]New in API 18
Unicode parameter value description string in UTF-16 encoding.

 

Remarks

This structure contains the possible numeric values for the given parameter. For more information, see the description of the VALUES command in the Parameter Script section of the GDL Reference Manual.

 

Requirements

Version: API 3.1 or later
Header: APIdefs_Goodies.h

 

See Also

APIAny_GetParamValuesID, API_GetParamValuesType, API Types