Section of a wall / curtain wall segment that neighbours a border line of the room.
typedef struct { API_Guid guid; Int32 roomEdge; Int32 filler; double tBeg; double tEnd; } API_WallPart, API_CWSegmentPart;
Members
- guid
- Guid of the wall.
- roomEdge
- Index of the room polygon edge adjacent to the wall.
- tBeg
- Beginning distance of the section from the beginning point of the wall.
- tEnd
- End distance of the section from the beginning point of the wall.
Remarks
The API_WallPart
structure is a member of API_RoomRelation. The following example shows how to interpret this data.
API_RoomRelation nWallPart 8 wallPart[0] wallPart[4] roomEdge 1 roomEdge 4 tBeg 0.15 tBeg 0.15 tEnd 5.85 tEnd 2.00 wallPart[1] wallPart[5] roomEdge 2 roomEdge 5 tBeg 0.15 tBeg 0.00 tEnd 3.85 tEnd 0.30 wallPart[2] wallPart[6] roomEdge 3 roomEdge 6 tBeg 0.15 tBeg 0.15 tEnd 1.85 tEnd 2.00 wallPart[3] wallPart[7] roomEdge 7 roomEdge 8 tBeg 2.15 tBeg 0.15 tEnd 5.85 tEnd 3.85
Requirements
- Version: API 1.3 or later
- Header: APIdefs_Elements.h