Structure for retrieving connection data of a wall.
typedef struct { API_Coord **coords; Int32 **pends; API_PolyArc **parcs; Int32 filler_1; API_Polygon connPoly; API_ConnectionGuidItem **conBeg; API_ConnectionGuidItem **conEnd; API_ConnectionGuidItem **conRef; API_ConnectionGuidItem **con; API_ConnectionGuidItem **conX; Int32 filler_2[5]; Int32 nConBeg; Int32 nConEnd; Int32 nConRef; Int32 nCon; Int32 nConX; Int32 filler_3[5]; } API_WallRelation;
Members
- coords
- Coordinates of the modified outline polygon
- pends
- Indices of the end coordinates of the subpolygons
- parcs
- Arc segments of the modified outline polygon
- connPoly
- Modified outline polygon due to the connections
- conBeg
- List of walls connected to the beginning point of the wall with their beginning or end point (see figure).
- conEnd
- List of walls connected to the end point of the wall with their beginning or end point (see figure).
- conRef
- List of walls connected with their reference line to the beginning or the end point of the wall (see figure).
- con
- List of walls connected to the reference line of the wall not at the endpoints (see figure)
- conX
- List of walls having intersection with the reference line of the wall (available from 2.1)
- nConBeg
- Number of
conBeg
indices - nConEnd
- Number of
conEnd
indices - nConRef
- Number of
conRef
indices - nCon
- Number of
con
indices - nConX
- Number of
conX
indices
Explanatory figure for wall relation cases
Remarks
To learn more about the usage of the wall relation structure please refer to the ACAPI_Element_GetRelations function.
Requirements
- Version: API 1.3 or later
- Header: APIdefs_Elements.h
See Also
ACAPI_Element_GetRelations, API_BeamRelation, API_CWPanelRelation, API_ConnectionGuidItem, API_Coord, API_PolyArc, API_Polygon, API Types