API_​WallType

Represents a wall element.

    typedef struct {
        API_Elem_Head                       head;
        short                               contPen;
        short                               contPen3D;
        API_AttributeIndex                  contLtype;
        API_AttributeIndex                  belowViewLineType;
        API_ModelElemStructureType          modelElemStructureType;
        API_AttributeIndex                  buildingMaterial;
        API_AttributeIndex                  composite;
        Int32                               sequence;
        Int32                               filler_0;
        API_PenOverrideType                 penOverride;
        API_OverriddenAttribute             refMat;
        API_OverriddenAttribute             oppMat;
        API_OverriddenAttribute             sidMat;
        API_AttributeIndex                   profileAttr;
        short                               profileType;
        bool                                polyCanChange;
        bool                                materialsChained;
        bool                                flipped;
        bool                                filler_1[7];
        API_WallTypeID                      type;
        API_WallReferenceLineLocationID     referenceLineLocation;
        double                              height;
        double                              bottomOffset;
        double                              topOffset;
        double                              thickness;
        double                              thickness1;
        double                              offset;
        double                              offsetFromOutside;
        double                              logHeight;
        Int32                               beamFlags;
        API_ZoneRelID                       zoneRel;
        char                                filler_2[16];
        bool                                isAutoOnStoryVisibility;
        bool                                inheritEndSurface;
        bool                                alignTexture;
        bool                                filler_3;
        API_StoryVisibility                 visibility;
        API_LinkToSettings                  linkToSettings;
        short                               relativeTopStory;
        short                               filler_4[3];
        API_Coord                           begC;
        API_Coord                           endC;
        API_Polygon                         poly;
        Int32                               rLinInd;
        Int32                               rLinEndInd;
        Int32                               refInd;
        Int32                               refEndInd;
        Int32                               oppInd;
        Int32                               oppEndInd;
        double                              angle;
        bool                                hasWindow;
        bool                                hasDoor;
        bool                                filler_5[2];
        Int32                               wallConnPriority;
        bool                                useCompositePriority;
        bool                                filler_6;
        short                               aboveViewLinePen;
        API_AttributeIndex                  aboveViewLineType;
        short                               filler_7;
        API_ElemDisplayOptionsID            displayOption;
        API_ElemViewDepthLimitationsID      viewDepthLimitation;
        double                              slantAlpha;
        double                              slantBeta;
        Int32                               filler_8[4];
    } API_WallType;

 

Members

head
General element header.
contPen
Pen attribute index of wall’s contour.
contPen3D
The pen index of wall’s contour in 3D.
contLtype
The linetype index of wall’s contour.
belowViewLineType Featuring API 11
Line type used when “OutLines Only” is selected from the “Floor Plan Display” popup. Corresponds to the “Uncut Lines” value in the Wall Settings dialog.
modelElemStructureType Featuring API 17
The structure type of the wall.
buildingMaterial Featuring API 17
Building Material index of wall’s hatch. Used only, if structure type is API_BasicStrucure.
composite Featuring API 17
Composite index of wall. Used only, if structure type is API_CompositeStructure.
sequence Featuring API 17
Sequence is required when two walls meet with the same priority or when 3 or more walls meet in a junction. It’s actual values can be between 0 and 999.
penOverride Featuring API 17
Cut fill pens set in the used structure (building material, composite, complex profile) can be overridden on the element level.
refMat Featuring API 17
Material override structure of the surface on the reference line side.
oppMat Featuring API 17
Material override structure of the opposite surface.
sidMat Featuring API 17
Material override structure of the side surfaces.
profileAttr Featuring API 10
Attribute index of the extruded profile (0 if not profiled). See API_ProfileAttrType.
Used only, if structure type is API_ProfileStructure.
profileType Featuring API 10
The type of the cross section of the wall:

APISect_Normal

Simple cross section element

APISect_Poly

Profiled cross section element

APISect_Slanted

Slanted cross section element

APISect_Trapez

Trapezoid cross section element

polyCanChange
The polygon wall’s corners can be changed in case of L and T connections.
materialsChained 20
Are surface materials chained?
flipped 17
If true then the wall is mirrored to the reference line. (true == APIWdir_Left or APIWdir_LCenter; false == APIWdir_Right or APIWdir_Center in the old API_WallDirID enum).
type
The type of the geometry of the wall (see API_WallTypeID).
referenceLineLocation
The location of the reference line (see API_WallReferenceLineLocationID).
height
The height of the wall relative to its bottom.
bottomOffset
Base height of the wall relative to the floor level.
topOffset Featuring API 17
The offset from top floor if wall is top linked.
thickness
The thickness of the wall at the beginning point.
thickness1
The thickness of the wall at the end point.
offset
The offset of the wall’s base line from reference line at the beginning point (invalid for center wall directions).
offset1
The offset of the wall’s base line from reference line at the end point (invalid for center wall directions).
logHeight
The height of the log for log walls (0 means normal wall).
beamFlags

APIWBeam_RefMater

Apply Reference side material on horizontal edges.

APIWBeam_OppMater

Apply Opposite side material on horizontal edges.

APIWBeam_HalfLog

Start with half log.

APIWBeam_QuadricLog

Use square (quadric) logs.

APIWBeam_Stretched

The log radius is measured from the opposite side.

APIWBeam_RightLog

The logs are curved on the right side of the wall.

APIWBeam_LeftLog

The logs are curved on the left side of the wall.

zoneRel
Defines the wall’s relation to zones (see API_ZoneRelID).
visibility Featuring API 10
The option to define which stories display the wall.
isAutoOnStoryVisibility Featuring API 10
Recalculate the story visibility automatically according to the actual vertical extent of the wall.
inheritEndSurface Featuring API 19
The end surface of the wall is inherited from the adjoining wall.
alignTexture Featuring API 19
Align texture mapping to wall edges.
linkToSettings Featuring API 11
Mode of linking to home story.
relativeTopStory Featuring API 17
The top linked story (relative to home story). Negative values are invalid. 0 = not top linked.
begC
The start (beginning) coordinate of the wall.
endC
The end coordinate of the wall.
poly
The original outline of the wall.
rLinInd
The index of the reference line beginning edge (starting from 1). Note that the direction can be reversed if the polygonal wall is mirrored.
rLinEndInd
The index of the reference line end edge.
refInd
The index of the reference material start edge index.
refEndInd
The index of the reference material end edge index.
oppInd
The index of the opposite side material edge start.
oppEndInd
The index of the opposite side material end edge index.
angle
The rotation angle of the wall in radians.
hasWindow Changed in API 12
Output only: true, if the Wall has at least one Window.
hasDoor Changed in API 12
Output only: true, if the Wall has at least one Door.
aboveViewLinePen Featuring API 10
Pen used when “Overhead All” is selected from the “Floor Plan Display” popup. Corresponds to the “Overhead Line Pens” value in the Wall Settings dialog.
aboveViewLineType Featuring API 10
Line type used when “Overhead All” is selected from the “Floor Plan Display” popup. Corresponds to the “Overhead Lines” value in the Wall Settings dialog.
displayOption Featuring API 10
Determines how the wall appears on the floor plan.
viewDepthLimitation Featuring API 10
Determines which part of the wall is visible for multi-story walls.
slantAlpha Featuring API 10
Defines the angle for slanted and double slanted walls.
slantBeta Featuring API 10
Defines the angle for double slanted walls.
offsetFromOutside 17
Distance between reference line and outside face of the wall (output only).

 

Remarks

Featuring API 17  In Archicad 17 the type of the elements’ structure is defined with the new modelElemStructureType member. The related attribute indices are separated into buildingMaterial, composite and profileAttr. The composite index is a non-negative index.

Featuring API 17  In Archicad 17 the the elements’ cut fill foreground and background pens inherit from the element structure, and can be overridden on the element level.

Featuring API 17  In Archicad 17 the the elements’ surface materials inherit from the element structure, and can be overridden on the element level.

For wall related memo data see the ACAPI_Element_GetMemo function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_WallTypeID, API_WallReferenceLineLocationID, API_ZoneRelID, API_Coord, API_AttributeIndex
API_StoryVisibility, API_LinkToSettings, API_ElemDisplayOptionsID, API_ElemViewDepthLimitationsID
API_Gable, API_Polygon, API_ProfileAttrType
API_Elem_Head, API_Element, API_ElementMemo
Element Manager, API Types