Describes the different calculated values for windows/doors.
typedef struct { double width1; double width2; double height1; double height2; double surface1; double surface2; double nWidth1; double nWidth2; double nHeight1; double nHeight2; double nSurface1; double nSurface2; double volume; double grossSurf; double grossVolume; double surface; double sillHeight; double sillHeight1; double sillHeight2; double headHeight; double headHeight1; double headHeight2; double sillHeight3; double headHeight3; double filler_1[7]; } API_WindowQuantity, API_DoorQuantity;
Members
- width1
- Window/door opening width on the reveal side
- width2
- Window/door opening width on the side opposite to the reveal side
- height1
- Window/door opening height on the reveal side
- height2
- Window/door opening height on the side opposite to the reveal side
- surface1
- Window/door opening surface on the reveal side
- surface2
- Window/door opening surface on the side opposite to the reveal side
- nWidth1
- Nominal window/door opening width on the reveal side
- nWidth2
- Nominal window/door opening width on the side opposite to the reveal side
- nHeight1
- Nominal window/door opening height on the reveal side
- nHeight2
- Nominal window/door opening height on the side opposite to the reveal side
- nSurface1
- Nominal window/door opening surface on the side opposite to the reveal side
- nSurface2
- Nominal window/door opening surface on the side opposite to the reveal side
- volume
- Window/door opening volume
- grossSurf
- Window/door opening nominal surface
- grossVolume
- Window/door opening nominal volume
- surface
- surface of the window/door
- sillHeight
- Window/door nominal sill height
- sillHeight1
- Window/door sill height on the reveal side
- sillHeight2
- Window/door sill height on the side opposite to the reveal side
- headHeight
- Window/door nominal head height
- headHeight1
- Window/door head height on the reveal side
- headHeight2
- Window/door head height on the side opposite to the reveal side
- sillHeight3
- Window/door sill height according to the vertical anchor.
- headHeight3
- Window/door head height according to the vertical anchor.
Remarks
See also the window parameters in Appendix A of the GDL Reference manual.
Requirements
- Version: API 15.0 or later
- Header: APIdefs_Elements.h
See Also
ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities, API_QuantityPar, API Types