API_​WindowType, API_​DoorType

Represents a window/door element.

    typedef struct {
        API_Elem_Head                           head;
        API_OpeningBaseType                     openingBase;
        API_WindowDoorRevealDepthLocationID     revealDepthLocation;
        double                                  revealDepthOffset;
        double                                  revealDepthFromSide;
        double                                  jambDepthHead;
        double                                  jambDepthSill;
        double                                  jambDepth;
        double                                  jambDepth2;
        bool                                    reveal;
        bool                                    filler_1[7];
        API_Guid                                owner;
        double                                  objLoc;
        double                                  lower;
        API_Coord                               startPoint;
        API_Coord                               dirVector;
        API_WindowDoorDirectionTypes            directionType;
        short                                   fixPoint;
        short                                   filler_2;
    } API_WindowType, API_DoorType;

 

Members

head
General element header.
openingBase Featuring API 15
Common part of windows, doors and skylights (see API_OpeningBaseType).
revealDepthLocation Featuring API 17
The location of the reveal depth reference line.

API_WindowDoorRevealDepthLocationID

APIWDRevealDepth_Side

The reference line location is on the clicked side of the wall.

APIWDRevealDepth_Core

The reference line location is on the core (clicked side) skin of the composite structure.

revealDepthOffset Featuring API 17
Inset from the clicked side of wall or core (according to revealDepthLocation).
revealDepthFromSide Featuring API 17
Calculated inset from the clicked side of wall.
jambDepthHead Featuring API 17
Inset on top.
jambDepthSill Featuring API 17
Inset on bottom.
jambDepth
Inset on left.
jambDepth2
Inset on right.
reveal
True if the opening has reveal.
owner Changed in API 12
Reference to the container wall (see API_Guid).
objLoc
Location of the center of the window. If the container wall is polygonal, this value is not used.
lower
Parapet height.
startPoint Featuring API 10
The location of the center point of the opening. It is measured from the beginning corner of the wall roof etc., rotated into the direction of the wall reference edge starting from the first corner. Note that this location can be outside of the wall polygon.
dirVector Featuring API 10
The direction vector of the opening in a polygonal wall, relative to the wall reference edge starting from the first corner.
directionType Featuring API 10
Type of the plane orientation of the window placed into slanted wall.

API_WindowDoorDirectionTypes

Meaning

API_WDAssociativeToWall

The plane of the window follows the plane of the wall

API_WDVertical

The window is placed vertically regardless of the plane of the wall it is placed into

fixPoint
The fixed (placement) point of the window/door (relative to the owning wall’s reference line):

APIHoleAnchor_BegFix

Beginning point is fixed.

APIHoleAnchor_CenterFix

Center point is fixed.

APIHoleAnchor_EndFix

End point is fixed.

 

Remarks

For window/door related memo data see the ACAPI_Element_GetMemo function.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_Elem_Head, API_OpeningBaseType
API_Element, API_SkylightType, API_ElementMemo
Element Manager, API Types