API_​WindowValidatorInfo

Holds information of elements and custom checksums which should be validated for the window

    struct API_WindowValidatorInfo {
        API_Guid      			guid;
        GS::Array<API_Guid>           	elemList;
        GS::Array<MD5::FingerPrint>	checkSumList;
    };

 

Members

guid
The GUID of the window.
elemList
List of elements important for the addon.
checkSumList
Custom list of checksum to validate along the given elements.

 

Remarks

This structure is used by the *WindowValidator functions, for further details refer to these sections.

 

Requirements

Version: API 22 or later
Header: APIdefs_Database.h

 

See Also

APIDb_BuildWindowValidator

APIDb_RebuildWindowValidator

APIDb_CheckWindowValidator

APIDb_DestroyWindowValidator
API Types