API_​WitnessID

Describes the various appearance options for witness lines.

    typedef enum {
        APIWtn_None,
        APIWtn_Small,
        APIWtn_Large,
        APIWtn_Fix
    } API_WitnessID;

 

Members

APIWtn_None
No witness line.
APIWtn_Small
Small witness line.
APIWtn_Large
Large witness line; the length of the witness line is given in the witnessVal field of API_DimElem.
APIWtn_Fix
Dynamic witness line; the size of the gap between the witness line and the element is given in the witnessVal field of API_DimElem.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Elements.h

 

See Also

API_DimensionType, API_RadialDimensionType, API_LevelDimensionType, API_AngleDimensionType, API_DimElem, API Types