API_​WorkingUnitPrefs

The representation of the Preferences / Units tab page.

    typedef struct {
        API_LengthTypeID     lengthUnit;
        API_AreaTypeID       areaUnit;
        API_VolumeTypeID     volumeUnit;
        API_AngleTypeID      angleUnit;
        short                roundInch;
        short                lenDecimals;
        short                areaDecimals;
        short                volumeDecimals;
        short                angleDecimals;
        short                angleAccuracy;
        Int32                filler_1[12];
    } API_WorkingUnitPrefs;

 

Members 

lengthUnit
The type of the length measurement unit.
areaUnit
The type of the area measurement unit.
volumeUnit
The type of the volume measurement unit.
angleUnit
The type of the angle measurement unit.
roundInch
1, 2, 4, 8, 16, 32, 64
lenDecimals
Number of decimals for length measurement unit. ( 0..4 )
areaDecimals
Number of decimals for area measurement unit. ( 0..4 )
volumeDecimals
Number of decimals for volume measurement unit. ( 0..4 )
angleDecimals
Number of decimals for angle measurement unit. ( 0..4 )
angleAccuracy
0..4

 

Remarks

This structure is used by the APIEnv_GetPreferencesID function to get the settings of the unit preferences page.

 

Requirements

Version: API 22 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_GetPreferencesID, API_LengthTypeID, API_AreaTypeID, API_VolumeTypeID, API_AngleTypeID, API Types