API_​WorkspaceInfo

Information on a team member’s workspace.

    typedef struct {
        Int32                nStories;
        Int32                nLayers;
        Int32                nSections;
        Int32                nCamSets;
        Int32                nDetails;
        Int32                nLayouts;
        Int32                nWorksheets;
        Int32                nElevations;
        Int32                nInteriorElevations;
        Int32                filler_1;
        short                **stories;
        short                **layers;
        API_DatabaseUnId     **sections;
        API_DatabaseUnId     **elevations;
        API_DatabaseUnId     **interiorElevations;
        API_Guid             **camSets;
        API_DatabaseUnId     **details;
        API_DatabaseUnId     **layouts;
        API_DatabaseUnId     **worksheets;
        Int32                workGroupMode;
        bool                 useMarquee;
        bool                 filler_2[7];
        API_Region           marquee;
    } API_WorkspaceInfo;

 

Members

nStories
number of reserved stories
nLayers
number of reserved layers
nSections
number of reserved section
nCamSets
number of reserved animations
nDetails Featuring API 10
number of reserved details
nLayouts Featuring API 10
number of reserved layouts
nWorksheets Featuring API 11
Number of reserved worksheets.
nElevations 11
Number of reserved elevations.
nInteriorElevations 11
Number of reserved interior elevations.
stories
the stories
layers
the layers
sections
the sections identified by their database unique ID
elevations 11
Elevations (db unId).
interiorElevations 11
Interior elevations (db unId).
camSets
the animations identified by camset element unId
details Featuring API 10
the details identified by database unId
layouts Featuring API 10
the layouts identified by database unId
worksheets 11
the worksheets identified by database unId
workGroupMode
Client access privilege level granted as teamwork role:
Value Meaning
APIWgMode_TeamMate Normal Teammate
APIWgMode_TeamLeader Team Leader
APIWgMode_TeamLeader_Excl Team Leader with Exclusive access
APIWgMode_ViewOnly View Only mode (cannot modify)
useMarquee
reservation is limited by the marquee area
marquee
the reserved area by the marquee

 

Remarks

Refer to the APIEnv_UserWorkspaceID function for more details.

Do not forget to dispose the handles with ACAPI_DisposeWorkspaceInfoHdls when they are not needed any more.

 

Requirements

Version: API 2.1 or later
Header: APIdefs_Environment.h

 

See Also

APIEnv_UserWorkspaceID
API_DatabaseUnId
API_Region
API Types
ACAPI_DisposeWorkspaceInfoHdls