Describes the different calculated values for zones.
typedef struct { double area; double perimeter; double holesPrm; double wallsPrm; Int32 allCorners; Int32 concaveCorners; double wallsSurf; double doorsWidth; double doorsSurf; double windowsWidth; double windowsSurf; double baseLevel; double floorThick; double height; double netarea; double netperimeter; double volume; double reducementArea; double calcArea; double totalExtrArea; double reducedExtrArea; double lowExtrArea; double wallExtrArea; double curtainWallExtrArea; double coluExtrArea; double fillExtrArea; double insetTopSurf; double insetBackSurf; double insetSideSurf; double filler[8]; } API_ZoneAllQuantity;
Members
- area
- measured area of the zone in square meters
- perimeter
- perimeter of the zone
- holesPrm
- perimeter of holes in the zone
- wallsPrm
- length of perimeter walls
- allCorners
- number of the corners of the zone
- concaveCorners
- number of concave corners of the zone
- wallsSurf
- surface area of perimeter walls
- doorsWidth
- combined width of all doors in the zone
- doorsSurf
- surface area of doors in the zone
- windowsWidth
- combined width of all windows in the zone
- windowsSurf
- surface area of windows in the zone
- baseLevel
- floor level of the zone
- floorThick
- subfloor thickness of the zone
- height
- height of the zone
- netarea
- net area of the zone
- netperimeter
- net perimeter of the zone
- volume
- the volume of the zone
- reducementArea
- zone area reducement
- calcArea
- calculated area of the zone
- totalExtrArea
- total extracted area of the zone
- reducedExtrArea
- reduced area of the zone
- lowExtrArea
- extracted low area of the zone
- wallExtrArea
- extracted wall area of the zone
- curtainWallExtrArea
- extracted curtain wall area of the zone
- coluExtrArea
- extracted column area of the zone
- fillExtrArea
- extracted fill area of the zone
- insetTopSurf
- wall inset top surface
- insetBackSurf
- wall inset back side surface
- insetSideSurf
- wall inset side surface
Remarks
See also the parameters of a zone stamp library part.
This structure replaces the previous API_ZoneQuantity
and API_ZoneExtraQuantity
structures.
Requirements
- Version: API 14 or later
- Header: APIdefs_Elements.h
See Also
ACAPI_Element_GetQuantities, ACAPI_Element_GetMoreQuantities, API Types