API_​ZoneCatType

Zone category attribute representation.

    typedef struct {
        API_Attr_Head     head;
        GS::uchar_t       catCode[API_UniLongNameLen];
        GS::uchar_t       stampName[API_UniLongNameLen];
        API_Guid          stampMainGuid;
        API_Guid          stampRevGuid;
        API_RGBColor      rgb;
    } API_ZoneCatType;

 

Members

head
Contains the name and the index of the zone category attribute.
catCode Modified in API 18
The Unicode (UTF-16) code for this category.
stampName Modified in API 18
The Unicode (UTF-16) name of the original zone stamp library part for this category.
stampMainGuid API 20
The main part of the unique identifier of the zone stamp library part.
stampRevGuid API 20
The revision part of the unique identifier of the zone stamp library part.
rgb
The RGB components of the zone color.

 

Remarks

This attribute exists in Archicad only.

One zone category always exists, i.e. you cannot delete the last zone category attribute.

There are additional data assigned to zone category attributes in the API_AttributeDef structure; the current values of the parameters are passed through the zone_addParItems field. Refer to the API_AddParType structure to get more details on it.

 

Requirements

Version: API 1.3 or later
Header: APIdefs_Attributes.h

 

See Also

API_RGBColor, API_Attr_Head, API_Attribute, API_AddParType, API_AttributeDef,
Attribute Manager, API Types