The representation of the Preferences / Zones tab page.
typedef struct { double nichDepth; double nichSize; unsigned char nichCombineMode; bool nichWindFlag; bool nichDoorFlag; bool nichDepthFlag; bool nichSizeFlag; bool filler_1; short filler_2; bool subtrWallFlag; bool subtrColuFlag; unsigned char subtrWallPercent; unsigned char subtrColuPercent; Int32 filler_3; double subtrWallSize; double subtrColuSize; unsigned char nLowAreas; bool filler_4; short filler_5; unsigned char roomRedPercents[4]; double roomHeightLimits[4]; Int32 filler_6[16]; } API_ZonePrefs;
Members
- nichDepth
- The depth of the recesses to Zone.
- nichSize
- The size of the recess to Zones.
- nichCombineMode
- The relation between depth and size variable. It can be one of the following constants:
APIRecess_And
,APIRecess_Or
- nichWindFlag
- Whether the recesses created by windows are included in the Zone size, depending on values of the
nichDepth
,nichSize
, and the relation of those. - nichDoorFlag
- Whether the recesses created by windows are included in the Zone size, depending on values of the
nichDepth
,nichSize
, and the relation of those. - nichDepthFlag
- Whether the minimal value for the depth of the wall recesses (
nichDepth
) is taken notice of . - nichSizeFlag
- Whether the minimal value for the size of the wall recesses (
nichSize
) is taken notice of . - subtrWallFlag
- Whether the areas of wall elements are subtracted from the Zone size.
- subtrColuFlag
- Whether the areas of columns elements are subtracted from the Zone size.
- subtrWallPercent
- Percent of subtraction for the wall elements from the Zone sizes.
- subtrColuPercent
- Percent of subtraction for the column elements from the Zone sizes.
- subtrWallSize
- The minimal square meters for the wall elements placed inside a Zone area to subtract areas of walls from Zone sizes.
- subtrColuSize
- The minimal square meters for the columns elements placed inside a Zone area to subtract areas of columns from Zone sizes.
- nLowAreas
- Number of height limits for ceiling reduction.
- roomRedPercents[4]
- The ratios for height limits (
roomHeightLimits
) to take into account for calculating Zone sizes. - roomHeightLimits[4]
- The height limits to take into account for calculating Zone sizes.
Remarks
This structure is used by the APIEnv_GetPreferencesID function to get the settings of the zone preferences page.
Requirements
- Version: API 2.1 or later
- Header: APIdefs_Environment.h