APIAddonObjectMergeHandlerProc

User supplied callback procedure for handling AddOnObject merge operations.

    typedef GSErrCode  APIAddonObjectMergeHandlerProc (
        const GS::Array<API_AddonObject>&     sourceAddOnObjectArray
    );

 

Parameters

sourceAddOnObjectArray
[in] The list of the source AddOnObjects.

 

Return Values

NoError
The function has completed with success.

For other common API errors see the API Errors document.

 

Remarks

This is the function to be called when a file merge operation is performed.

The handler function should merge the source objects into the project database by calling AddOnObject-related API functions (e.g. ACAPI_AddOnObject_ModifyObject).

 

Requirements

Version: API 19 or later
Header: APIdefs_Callback.h

 

See Also

API_AddonObject
ACAPI_Install_AddOnObjectMergeHandler
ACAPI_Register_AddOnObjectHandler
AddOnObject Manager
API Functions