APIAny_​AddMDCLParameterID

Appends a parameter to the parameter list.

    GSErrCode ACAPI_Goodies (
        APIAny_AddMDCLParameterID,
        GSHandle               params,
        API_MDCLParameter*     mDCLParameter
    );

 

Parameters

params
[in/out] Handle of the parameter list
mDCLParameter
[in] Pointer to the parameter to be appended

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
params, par or par->name is nullptr,
or par->type is invalid
APIERR_BADNAME
The given parameter name is already used in the parameter list
APIERR_MEMFULL
low memory condition

For other common API errors see the API Errors.

 

Remarks

This function is used to append a parameter to the parameter list used in inter-addon communications.
For the utilization details of APIAny_AddMDCLParameterID refer to the Parameter Passing section of the Communication Manager.

 

Example

See the Communication_Manager example.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

Communication Manager
API_MDCLParameter
APIAny_ChangeMDCLParameterID
APIAny_FreeMDCLParameterListID
APIAny_GetMDCLParameterID
APIAny_GetMDCLParameterNumID
APIAny_InitMDCLParameterListID
ACAPI_Command_Call
ACAPI_Command_Test
ACAPI_Goodies
API Functions