Converts the reveal depth offset from wall side to core skin for wall openings.
GSErrCode ACAPI_Goodies ( APIAny_CalcSideOffsetToCoreOffsetID, const API_Guid* wallOpeningGuid, const double* sideOffset, double* coreOffset );
Parameters
- wallOpeningGuid
- [in] Unique ID of the WallOpening element.
- sideOffset
- [in] Reveal depth offset from wall side.
- coreOffset
- [out] Reveal depth offset from core skin.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- wallOpeningGuid or sideOffset or coreOffset is
nullptr
. APIERR_BADID
- wallOpeningGuid does not refer to a valid element in the database.
APIERR_REFUSEDPAR
- The element specified with wallOpeningGuid is not WallOpening type, or owner wall of opening is not exist.
For other common API errors see the API Errors document.
Remarks
This function can be used for wall openings in composite walls (side offset and core offset is equal in walls with basic structure).
Requirements
- Version: API 17 or later
- Header: APIdefs_Goodies.h
See Also
ACAPI_Goodies,
API Functions,
APIAny_CalcSideOffsetToCoreOffsetID