APIAny_​ChangeAParameterID

Changes a value in an opened Library Part parameter list.

    GSErrCode ACAPI_Goodies (
        APIAny_ChangeAParameterID,
        API_ChangeParamType*     changeParamType,

    );

 

Parameters

changeParamType
[in] The Library Part parameter (variable) to change the value of it.

 

Return Values

NoError
The function has completed with success.
APIERR_BADPARS
chgParam is nullptr or the variable reference is invalid
APIERR_NOTINIT
there is no parameter list opened

For other common API errors see the API Errors.

 

Remarks

This function is used to change a Library Part parameter. Refer to the API_ChangeParamType structure to get details on the parametrization possibilities.

Use this function after a parameter list has been opened by the APIAny_OpenParametersID function. Refer to that function to get more details on this topics.

This function is a non-undoable data structure modifier function. See more details on this topic at Command Overview.

 

Example

See the example given at the APIAny_OpenParametersID function.

 

Requirements

Version: API 4.1 or later
Header: APIdefs_Goodies.h

 

See Also

API_ChangeParamType,
APIAny_OpenParametersID,
ACAPI_Goodies, API Functions