Switches autotexts to be replaced with their current values or kept as autotext keys in retrieved texts.
GSErrCode ACAPI_Goodies ( APIAny_ChangeAutoTextFlagID, bool* showAutoText );
Parameters
- showAutoText
- [in] The value of the autotext flag to be set.
Return Values
NoError
- The function has completed with success.
APIERR_BADPARS
- The passed
showAutoText
parameter isnullptr
.
For other common API errors see the API Errors document.
Remarks
This function is used to set the flag which determines whether ACAPI_Element_GetMemo function retrieves the original content of the text or textual label element [false] (the database representation), or the interpreted one [true] (what you see on the user interface).
You can retrieve this flag with the APIAny_GetAutoTextFlagID function.
Example
bool currAutoTextFlag; ACAPI_Goodies (APIAny_GetAutoTextFlagID, &currAutoTextFlag, nullptr); bool setAutoTextFlag = false; ACAPI_Goodies (APIAny_ChangeAutoTextFlagID, &setAutoTextFlag, nullptr); // autotexts now are kept as keys in the retrieved text content // when calling ACAPI_Element_GetMemo for textual elements ACAPI_Goodies (APIAny_ChangeAutoTextFlagID, &currAutoTextFlag, nullptr);
Requirements
- Version: API 10 or later
- Header: APIdefs_Goodies.h