Checks whether a library part unique ID refers to a subtype of another.
GSErrCode ACAPI_Goodies ( APIAny_CheckLibPartSubtypeOfID, char* successorUnIDStr, char* predecessorUnIDStr );
Parameters
- successorUnIDStr
- [in] the unique ID of the subtype.
- predecessorUnIDStr
- [in] the unique ID of the expected ancestor.
Return Values
NoError
- The function has completed with success and the ancestry holds.
APIERR_NOTSUBTYPEOF
- The function has completed with success but the first one is not a subtype of the second.
APIERR_BADPARS
- any of the parameters are
nullptr
.
For other common API errors see the API Errors document.
Remarks
This function is used to verify that a library part identified by its unique ID is a subtype of the other one.
No existence check is performed for the predecessor.
It checks for real ancestry so returns APIERR_NOTSUBTYPEOF for equal unique IDs as well.
Requirements
- Version: API 4.1 or later
- Header: APIdefs_Goodies.h